PDF Manager Login Error
Major incident
Beezy365Apps Online Services
PDF Manager
2026-04-13 20:59 -11
· 23 hours, 29 minutes
Updates
Resolved
April 14, 2026 · 20:27 -11
Issue is now solved, sorry for the inconvenience.
Greetings
Beezy365 apps team
Investigating
April 13, 2026 · 20:59 -11
Some users might experience a login error when clicking on any PDF manager tabs.
We are working on it.
Greeting
Beezy365 apps team.
← Back
Apps Status